home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-kernel / gentoo-sources-2.6.14-r4 / gentoo-sources-2.6.14-r4.ebuild < prev    next >
Text File  |  2005-12-08  |  1KB  |  43 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.6.14-r4.ebuild,v 1.2 2005/12/07 19:11:01 dsd Exp $
  4.  
  5. ETYPE="sources"
  6. K_WANT_GENPATCHES="base extras"
  7. K_GENPATCHES_VER="5"
  8. IUSE="ultra1"
  9. inherit kernel-2
  10. detect_version
  11. detect_arch
  12.  
  13. KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 x86"
  14.  
  15. HOMEPAGE="http://dev.gentoo.org/~dsd/genpatches"
  16.  
  17. DESCRIPTION="Full sources including the gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
  18. SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
  19.  
  20. pkg_setup() {
  21.     if use sparc; then
  22.         # hme lockup hack on ultra1
  23.         use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 1399_sparc-U1-hme-lockup.patch"
  24.     fi
  25. }
  26.  
  27. pkg_postinst() {
  28.     postinst_sources
  29.  
  30.     echo
  31.  
  32.     if [ "${ARCH}" = "sparc" ]; then
  33.         if [ x"`cat /proc/openprom/name 2>/dev/null`" \
  34.              = x"'SUNW,Ultra-1'" ]; then
  35.             einfo "For users with an Enterprise model Ultra 1 using the HME"
  36.             einfo "network interface, please emerge the kernel using the"
  37.             einfo "following command: USE=ultra1 emerge ${PN}"
  38.         fi
  39.     fi
  40.     einfo "For more info on this patchset, and how to report problems, see:"
  41.     einfo "${HOMEPAGE}"
  42. }
  43.